Chapter 2: Origin Basics

Origin Basics

Topography of an Origin Project and Workspace

When you start Origin, a new project opens displaying a worksheet window in the workspace. The worksheet is one type of window available in Origin. Origin also provides graph (including function graph), layout page, Excel workbook, matrix, and notes windows. Having various windows allows you to simultaneously view different visual representations of your data - such as data in a worksheet versus a graph - simplifying data manipulation and analysis.

Menus and Menu Commands

Origin's menu bar provides commands to perform operations on the active window and to perform general operations such as opening a Help file or turning on the display of a toolbar. The menu bar changes as you change the active window. For example, the following figures compare the worksheet and graph menu bars.

*The Worksheet Window Menu Bar*

File Edit View Plot Column Analysis Statistics Tools Format Window Help

*The Graph Window Menu Bar*

File Edit View Graph Data Analysis Tools Format Window Help

Menus are also sensitive to the active window. For example, the following figure compares the worksheet and graph Analysis menus.
Origin provides two menu "levels" which determine the number of menu commands that are available. By default, Origin displays the "full menu", which means that all available menu commands are provided. However, Origin also offers a "short menu" level, which provides a reduced set of menu commands for performing basic operations only. To activate this reduced set of commands, select \texttt{Format:Menu:Short Menus}. At any time you can re-activate the full set of commands by selecting \texttt{Format:Menu:Full Menus}.

Some menu commands have shortcut keys associated with them. If available, the shortcut key displays to the right of the menu command. For example, when a worksheet window is active, you can press \texttt{CTRL+F5} to access \texttt{Set All Column Values}.

\textbf{Note:} You can't use a shortcut key if the menu is open.

Some menu commands also have bitmaps that display to the left of the command. The bitmap indicates that the menu command also has toolbar button access. To access the command from a toolbar, look for the toolbar button represented by the command's bitmap.

\textit{Accessing a Command from a Toolbar}

(To learn how to open additional toolbars, such as the Worksheet Data toolbar, see "Toolbars" on page 7.)
To turn off the display of bitmaps in the menus, select **Tools:Options** to open the Options dialog box. Select the Miscellaneous tab and then clear the Display Bitmaps in Menus check box. After you click OK, you are asked if you want to save this setting for future Origin sessions.

Many commands are also available from shortcut menus. To open a shortcut menu, right-click on the object you want to perform an action on. For example, if you right-click on a text label, the shortcut menu in the following figure opens.

**Opening a Shortcut Menu**

![Shortcut Menu](image)

**Toolbars**

Origin provides toolbar buttons for frequently used menu commands. As with menu commands, some toolbars are only available when a particular window (for example, a worksheet) is active. Additionally, a toolbar that is available for multiple window types may contain buttons that are window-sensitive.

When you position the mouse pointer over a toolbar button, a view box opens displaying the button name, which indicates its purpose. A more detailed description also displays in the status bar.

**Viewing a Button's Name and Purpose**

![Toolbar buttons](image)

If you open Excel workbooks in Origin, when you change the active window from an Excel workbook to any other window type (for example, a worksheet), or when you close an Excel workbook, the toolbar region displays a blank area where the Excel toolbars were located (see the following figure).
Blank Area in the Toolbar Region

This area is called a toolbar spacer. To hide the toolbar spacer, right-click in the region and select **Hide Toolbar Spacer** from the shortcut menu. When you re-activate the Excel workbook window or re-open a workbook, Origin will automatically show the toolbar spacer with the Excel toolbars. (To prevent Origin from using the toolbar spacer, select **Tools:Options** to open the Options dialog box. Select the Miscellaneous tab and then clear the Use Toolbar Spacer check box. After you click OK, you are asked if you want to save this setting for future Origin sessions.)

When you first start Origin, the following toolbars are available: Standard, Graph, Format, Style, Tools, and 2D Graphs.

**The Standard Toolbar**

The Standard toolbar provides buttons for opening, saving, and creating new projects and windows, and for importing ASCII data. It also provides buttons for general window operations such as printing, duplicating, and refreshing windows. The Standard toolbar provides buttons for opening Project Explorer, the Results Log, the Script window, and Code Builder. A button is provided for custom programming. A button is also provided for adding a column to the worksheet.

**The Graph Toolbar**

The Graph toolbar is available when a graph or layout page is active. It provides buttons to zoom in and out and to rescale axes to show all the data. It provides buttons to display data plots in multiple layers, display layers in multiple windows, and to merge windows. Labeling buttons are available for legends and a time/date stamp.
The Format Toolbar

The Format toolbar is available when a text label is active. This toolbar provides text formatting buttons. Color control is available from the Style toolbar.

Note: The Greek button uses the Symbol font set. To associate the button with a different font set, select Tools:Options to open the Options dialog box. Select the Text Fonts tab and then select the desired font set from the Greek drop-down list.

The Style Toolbar

The Style toolbar is available when a text label or other annotation is selected. It provides buttons to set the line and fill color, style, and point size.

The Tools Toolbar

The Tools toolbar provides text, arrow, line, and other annotation buttons. It also provides buttons to enlarge a region of a graph. The Tools toolbar also provides buttons to read the XY (and Z, if 3D or contour) location on the page and the XY (and Z) location of a data point. You can also define a range of data. Furthermore, a button is provided to draw a data plot. Note: If you are viewing an image in a matrix, you can display the Rectangle tool in the "region of interest" mode. The region of interest mode allows you to select a region of the image to crop, copy, or duplicate. The region of interest mode is controlled from the Tools:Show Tools as ROI menu command.

The 2D Graphs Toolbar

The 2D Graphs toolbar is available when a worksheet, Excel workbook, or graph window is active. It provides buttons for the common 2D graph templates, and for accessing a custom graph template.
When a worksheet or Excel workbook is active, first select the data that you want to plot and then click the button on the 2D Graphs toolbar to plot your data.

When a graph window is active, you can change the graph type (for example, from scatter to column) for the active data plot. To activate a data plot, select the data plot from the Data menu. Then click the button on the 2D Graphs toolbar to change the graph type.

In addition to these default toolbars, you can open the following additional toolbars. To do this, select View: Toolbars to open the Customize Toolbar dialog box. Then select the desired toolbar from the Toolbars tab.

The Edit Toolbar

The Edit toolbar provides cut, copy, and paste buttons.

The 2D Graphs Extended Toolbar

The 2D Graphs Extended toolbar is available when a worksheet, Excel workbook, or graph window is active. It provides buttons for the additional 2D graph templates not accessible from the 2D Graphs toolbar.

The 3D Graphs Toolbar

The 3D Graphs toolbar is available when a worksheet, Excel workbook, or matrix is active. The first two buttons are available for plotting XYZ data. The next four buttons are available for plotting XYY data. The remaining buttons are available for plotting matrices. The last button, the Image Plot button, is available for plotting images.
Chapter 2: Origin Basics

The 3D Rotation toolbar is available when a 3D graph is active. This toolbar provides buttons to rotate the graph and change the perspective.

*The Worksheet Data Toolbar*

The Worksheet Data toolbar is available when a worksheet is active. This toolbar provides buttons to perform statistics on columns or rows of data, sort, use functions to set column values or mathematically transform values, update these column values, and fill columns with row numbers or random numbers.

*The Column Toolbar*

The Column toolbar is available when a worksheet column is selected. It provides buttons to set the column plotting designation and to move columns.

*The Layout Toolbar*

The Layout toolbar is available when a layout page is active. It provides buttons to add pictures of graphs or worksheets to the layout page.

*The Mask Toolbar*

The Mask toolbar is available when a worksheet or graph is active. This toolbar provides buttons to mask data from analysis.

*The Object Edit Toolbar*

The Object Edit toolbar is available when one or more annotation objects are selected in the active window, or when more than one picture is selected in a layout page. The toolbar provides buttons to align the selected objects/pictures, and to change the drawing order of the objects/pictures. Buttons are provided
to group objects so that you can move or align the group. Additionally, buttons are provided to change the drawing order of objects relative to data plots.

*The Arrow Toolbar*

The Arrow toolbar is available when one or more lines or arrows are selected. This toolbar provides buttons to align multiple lines/arrows, and to customize the arrow head.

In addition to adding Origin's default toolbars to your workspace, you can add and remove buttons from any of the default toolbars, or create new toolbars containing a single button or a combination of buttons from the default toolbars.

To add and remove buttons from any of Origin's default toolbars, select **View: Toolbars** to enter the toolbar editing mode. You can now drag toolbar buttons between toolbars. To remove a button from a toolbar, drag the button off the toolbar (not on to another toolbar) and release the mouse button. To add a button to a toolbar, select the Button Groups tab on the Customize Toolbar dialog box. From the Groups list box, select the toolbar which displays the button by default. Then drag the desired button onto any of the toolbars.

To create a new toolbar, you can drag a button into the workspace or into the toolbar region (not on to another toolbar). Alternatively, click New on the Toolbars tab of the Customize Toolbar dialog box. Type the desired name in the New Toolbar dialog box and click OK. Now select the Button Groups tab and drag the desired buttons onto the new toolbar.

*Creating a New Toolbar*

**Window Types**

Origin provides a number of window types for viewing, analyzing, and presenting your data. These windows include worksheet, matrix, Excel workbook, graph, layout page, and notes windows. The window type that is currently active in the Origin workspace determines the menu bar and toolbars that are available.

*Worksheet Windows*

A worksheet's primary function is to hold and organize the data that you bring into Origin, and to provide tools for data manipulation, exploration, statistics, analysis, and plotting.
The columns in a worksheet are related to one another by their plotting designation (such as X and Y) and their location. The plotting designation determines how the selected data will plot. For example, in the following worksheet, if you select columns A through E and then click the Line & Symbol button on the 2D Graphs toolbar, columns A and B, C and D, and C and E will plot as XY pairs.

Worksheet Column Plotting Designations

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>1.5</td>
<td>3</td>
<td>0.4</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>2</td>
<td>6</td>
<td>0.3</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>6</td>
<td>2.5</td>
<td>9</td>
<td>0.2</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>8</td>
<td>3</td>
<td>12</td>
<td>0.1</td>
<td>1</td>
</tr>
</tbody>
</table>

Worksheet Menu Bar

The File menu provides Origin project and window commands that are available independent of the active window. When a worksheet is active, the File menu also provides commands to:
=> import and export data

The Edit menu provides cut, copy, paste, and undo commands that are available independent of the active window. Additionally, a "button edit mode" command is available for editing programmed labels. When a worksheet is active, the Edit menu also provides commands to:
=> set the worksheet display range
The View menu provides commands to control the display of the Project Explorer window, toolbars, status bar, and Results Log. It also provides a command to display a grid for aligning objects. These commands are available independent of the active window. When a worksheet is active, the View menu also provides commands to:

- update a graph after changing the worksheet data
- go to a specified worksheet row
- show a hidden X column

The Plot menu is only available when a worksheet, matrix, or Excel workbook is active. The Plot menu provides commands to:

- plot data into a specified graph template

The Column menu is only available when a worksheet is active. This menu provides commands to:

- set the column's plotting designation
- use functions to set column values or mathematically transform values
- add and move columns

The Analysis menu provides commands to:

- extract data
- sort data
- normalize data
- perform FFT-related operations
- perform nonlinear curve fitting

The Statistics menu is only available when a worksheet is active. This menu provides commands to:

- perform a number of statistical tests on your data

The Tools menu command provides commands to set global preferences in the Options dialog box, reactivate reminder messages, and pack selected files into a single file to share with other Origin users. These commands are available independent of the active window. When a worksheet is active, the Tools menu also provides commands to:

- associate LabTalk script with the worksheet
- perform linear, polynomial, and sigmoidal fitting
- compare two columns of data by fitting the same function to the data

The Format menu provides commands to display a reduced menu structure in which only basic operations are available, to edit the name and programming-related properties of a label, and to align objects to a grid. These commands are available independent of the active window. Additionally, the worksheet Format menu provides commands to:

- set the worksheet or column display options
- set incremental X values in a worksheet without a designated X column

The Window menu provides commands to arrange the windows in the workspace, open the Script window, activate a Project Explorer folder, and activate a window in the workspace. These commands are available independent of the active window.
The Help menu provides commands to open the Origin and programming-related Help files, open a dialog box with tips on using Origin, go to the OriginLab web site, and register your copy of Origin. These commands are available independent of the active window.

**Graph Windows**

A graph window is a container and editor for creating graphs. Each graph window contains a single editable page. The page serves as a backdrop for the various graph objects, including layers, axes, annotations, and data plots.

There are many ways to create graphs in Origin. The easiest method is to select the worksheet data that you want to plot, and then select the desired graph type from the Plot menu or from one of the plotting toolbars. If you've already created a graph window, you can select and drag data from a worksheet into the graph window.

*A Graph with Multiple Layers*

![Graph with Multiple Layers](image)

**Graph Menu Bar**

(See the Worksheet Menu Bar for commands that are available for all window types.)

The File menu provides graph-specific commands to:

- import ASCII data
- import an image file
- export the graph to an image file

The Edit menu provides graph-specific commands to:

- copy a graph to the clipboard
Chapter 2: Origin Basics

- add and arrange layers in the active graph
- rotate the graph between landscape and portrait orientation
- merge all the graph windows into one window

The **View** menu provides graph-specific commands to:
- view the graph using the screen driver or active printer driver
- zoom in and out of the graph
- show or hide elements in the graph
- resize the active graph layer so that it fills the page
- resize the graph window so that it fills the screen

The **Graph** menu provides commands to:
- add data to the graph, including error bars or a function
- rescale the axes and exchange the X and Y axes
- create a new legend or color scale for color mapped data
- stack grouped data (most useful for column and bar charts)

The **Data** menu provides graph-specific commands to:
- set the display range
- move and remove data points

The **Data** menu also lists the data sets that are plotted in the active graph. The active data set is checked.

The **Analysis** menu provides graph-specific commands to:
- perform linear and nonlinear fitting
- perform math operations
- smooth or filter the data
- differentiate and integrate
- perform a subtraction or translation
- average curves
- perform interpolation and extrapolation
- perform an FFT

The **Tools** menu provides graph-specific commands to:
- open analysis and fitting tools
- open a tool for adding and arranging layers
- compare two sets of data by fitting the same function to the data

The **Format** menu provides graph-specific commands to:
- set the page, layer, data plot, and axes display options

**Layout Page Windows**

A layout page window is a “display panel” for graphs and worksheets that have been created in other windows. You can add and arrange worksheet and graph pictures in a layout page, as well as text and other annotations.
A Layout Page Window

The graph displays a Schild plot on the effect of an antagonist on an agonist-induced contraction (response) in some tissue.

Parameters from Linear Regression:
- Slope = 1.05918 ± 0.12537
- Inter. = 7.43445 ± 0.75397
- Statistics:
  - R = 0.97266, R^2
  - (CCD) = 0.94867

Layout Page Menu Bar

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Layout</th>
<th>Tools</th>
<th>Format</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
</table>

(See the Worksheet Menu Bar for commands that are available for all window types.)

The **File** menu provides layout page-specific commands to:
- => import an image file
- => export the layout page to an image file

The **Edit** menu provides layout page-specific commands to:
- => copy a layout page to the clipboard
- => rotate the layout page between landscape and portrait orientation

The **View** menu provides layout page-specific commands to:
- => view the layout page using the screen driver or active printer driver
- => zoom in and out of the layout page
- => show master page items in the layout page

The **Layout** menu is only available when a layout page is active. This menu provides commands to:
- => add pictures of graphs or worksheets
- => view picture placeholders to increase redraw speed
- => view pictures using the screen driver to increase redraw speed

The **Format** menu provides layout page-specific commands to:
- => set the page display options
Excel Workbook Windows

You can open Excel workbooks inside Origin, combining Origin's plotting and analysis power with Excel's spreadsheet tools. To plot your workbook data in Origin, you must have Excel version 7 (Microsoft Office 95) or later installed on your computer either as a local or network copy.

Note: When you change the active window from an Excel workbook to any other window type, the toolbar region displays a blank area where the Excel toolbars were located. To hide this spacer, right-click in this region and select Hide Toolbar Spacer from the shortcut menu.

Opening an Excel Workbook in Origin

Excel Workbook Menu Bar

```
Excel Workbook Windows

You can open Excel workbooks inside Origin, combining Origin's plotting and analysis power with Excel's spreadsheet tools. To plot your workbook data in Origin, you must have Excel version 7 (Microsoft Office 95) or later installed on your computer either as a local or network copy.

Note: When you change the active window from an Excel workbook to any other window type, the toolbar region displays a blank area where the Excel toolbars were located. To hide this spacer, right-click in this region and select Hide Toolbar Spacer from the shortcut menu.

Opening an Excel Workbook in Origin

Excel Workbook Menu Bar

When an Excel workbook is active in Origin, the menu bar displays both Origin and Excel menus. The File, Plot, and Window menus are Origin menus. All other menus are Excel menus.

The File menu provides Origin project and window commands.

The Plot menu provides commands to plot data into a specified graph template.

The Window menu provides commands to:
- set global preferences in the Options dialog box
- control the display of the Project Explorer window, toolbars, and Results Log
- convert an Excel workbook to a matrix using direct conversion
```
=> arrange the windows in the workspace, open the Script window, activate a Project Explorer folder, and activate a window in the workspace

**Matrix Windows**

A matrix displays a single data set containing Z values. Instead of displaying the data set as a column in a worksheet, a matrix displays the data in a specified dimension of rows and columns. A matrix is linearly mapped in X by columns and linearly mapped in Y by rows. By default, the column and row numbers display in the column and row headings. To display the X and Y values, select View:Show XY.

*Showing the X and Y Matrix Values*

Origin provides a number of methods for converting a worksheet to a matrix. This includes direct conversion, 2D binning, converting regular XYZ data, and converting random XYZ data using gridding. These conversion methods are available from the worksheet's Edit:Convert to Matrix submenu.

When a matrix is active, you can create 3D, surface, contour, and image plots.

**Matrix Menu Bar**

(See the Worksheet Menu Bar for commands that are available for all window types.)

The **File** menu provides matrix-specific commands to:

=> import and export data

=> import and export image files

The **Edit** menu provides matrix-specific commands to:

=> convert the matrix to a worksheet

The **View** menu provides matrix-specific commands to:

=> when viewing an image, zoom in and out of the image

=> when viewing data, go to a specified row

=> switch between data mode and image mode

=> show the column and row numbers or show the XY mapping for the Z values

The **Plot** menu provides commands to plot data into a specified graph template.
Chapter 2: Origin Basics

Topography of an Origin Project and Workspace

The **Matrix** menu is only available when a matrix is active. This menu provides commands to:

- set matrix properties such as the internal data type and the display format
- set the matrix dimensions and the XY mapping relationship
- use functions to set the matrix values or mathematically transform values
- transpose, invert, shrink using averaging, expand using bilinear interpolation, smooth, or integrate the matrix

The **Image** menu is only available when a matrix is active. This menu provides commands to:

- display images using selected color palettes
- open a tool to adjust the brightness and contrast in the image

The **Tools** menu provides matrix-specific commands to:

- display the Tools toolbar tools in the "region of interest mode" for selecting a region to copy, crop, or create a new matrix

**Notes Windows**

Notes windows can contain only text, and are thus used for recording information.

*A Notes Window*

![Notes Window Example]

**Notes Menu Bar**

File Edit View Layout Tools Format Window Help

(See the Worksheet Menu Bar for commands that are available for all window types.)

The **View** menu provides notes-specific commands to:

- enable word wrapping

**Project Explorer**

Project Explorer is a tool to help you organize your Origin projects. It is particularly useful if you are working with a project that contains more than a few windows. You can use Project Explorer to develop a
folder structure for organizing the windows in your project. You can also use Project Explorer to control the view of your workspace.

When you first start Origin, Project Explorer displays docked to the bottom edge of the workspace. You can dock it to any other edge or display it as a window in the workspace. To prevent Project Explorer from docking when positioning it as a window, press CTRL while dragging.

**Project Explorer**

To create a new folder, right-click on the project folder (or a subfolder) and select New Folder from the shortcut menu. Once you have created one or more subfolders, you can move windows between folders.

**Creating a New Folder**

In addition to adding and moving folders, Project Explorer also controls the view of your workspace. By default, only the windows in the active Project Explorer folder display in your workspace. For projects with lots of windows, this allows you to focus on specific windows in a clutter-free workspace.

To control the view of the windows in your workspace, right-click on a Project Explorer folder or right-click in a blank space on the left side of Project Explorer. Select View: View Mode to alter the view mode. (Alternatively, select View: View Windows: View Mode from the Origin menu bar.)

**Controlling the View of Windows in the Workspace**

None

Windows in Active Folder

Windows in Active Folder & Subfolders
Chapter 2: Origin Basics

After you organize your windows into multiple folders, Project Explorer's Find dialog box helps you locate windows in your project. To open this dialog box, right-click on the Project Explorer folder that you want to start your search from and select Find from the shortcut menu. If you are unsure of the window location within your Project Explorer folder structure, right-click on the main project folder and select Find.

Finding Windows in Your Project

![Find dialog box]

Because Project Explorer uses some of your workspace, you may want to close Project Explorer, even if you have already created a folder structure. To close Project Explorer, click the Project Explorer button on the Standard toolbar.

When Project Explorer is closed, Origin continues to use your folder structure and view settings to display the windows in your workspace. Thus, if you are working with a project that contains subfolders, and the view mode is set to view only the active folder's windows, then Origin will display the windows in your currently active folder.

To access windows in other folders, you can re-open Project Explorer or you can select Window:Folders:Folder Name to view the windows in the selected Project Explorer folder. The window list at the bottom of the Window menu updates to reflect the windows in the Folder Name folder.

Accessing Folders and Windows from the Menu Bar

![Menu bar with Folders]

Topography of an Origin Project and Workspace • 22
If you have more than nine windows in your current Project Explorer folder and you want to view a window that is not currently listed in the window list at the bottom of the Window menu, select Window: More Windows. This menu command opens the Windows dialog box.

The Windows dialog box can be resized by clicking and dragging on the edge of the dialog box. The dialog box displays the names (and/or labels), window type, and current status of all the windows in the current Project Explorer folder, or the current folder and subfolders, depending on your Project Explorer viewing mode.

The Windows Dialog Box

To activate a window:
Double-click on the window in the list box or click once on the window and click Activate. Click Close to close the dialog box and view the active window.

To sort the windows:
To sort the windows alphabetically by name (or label), or by window type or state, click the associated button at the top of the list box.

To minimize or restore a window:
Select the window from the list box and click Minimize Window or Restore Window.

To close a window so that it is no longer part of the project:
Select the window from the list box and click Close Window. To verify closure, click Yes in the Attention dialog box. To disable the display of the Attention dialog box, select the Disable Close Prompt check box.
Results Log

Origin automatically routes most analysis and fitting results to the Results Log. In most cases, when results are output to the Results Log, it opens automatically. However, to manually open (and close) the Results Log, click the Results Log button on the Standard toolbar. Opening and closing the Results Log only controls its view state. You do not lose results by closing the log.

When the Results Log first opens, it displays docked to the top edge of the workspace. You can dock it to any other edge or display it as a window in the workspace. To prevent the Results Log from docking when positioning it as a window, press CTRL while dragging.

Each entry in the Results Log includes a date/time stamp, the window name, a numeric stamp which is the Julian day, the type of analysis performed, and the results.

The Results Log

```
2/23/2001 20:33  "Graph1" (2452236)
Data: CAUSSION_Hmpl
Model: Gauss
Equation: y=y0 + (A/\sqrt{\pi}) \exp(-2*(x-xc)^2)/\sigma^2

Chi^2/DoF  R^2
8.87158  0.98844

Parameter Value Error
y0  1.8249  0.62492
xc  24.90625 0.0923
w   10.26232 0.21944
A   998.75604 23.08163
```

You can right-click in the Results Log to open a shortcut menu with commands to copy, print, clear, and view additional results.

The Results Log Shortcut Menu

- Copy
- Select All
- Print
- Clear...
- Clear All
- Clear Last Entry
- Restore Last Cleared Entry
- View All Results
  - View Results in Active Folder
  - View Results in Active Folder & Subfolders
- Auto Open
Note: When you close the Results Log after it has been docked to the edge of the workspace, the toolbar region may display a blank area where the log was located. To hide this spacer, right-click in this region and select \textbf{Hide Toolbar Spacer} from the shortcut menu.

\section*{Code Builder}

Origin's programming language is called Origin C. Origin C supports a nearly complete ANSI C language syntax as well as a subset of C++ features including internal and DLL-extended classes. In addition, Origin C is "Origin aware". This means that Origin objects such as worksheets and graphs are mapped to classes in Origin C, allowing direct manipulation of these objects and their properties from Origin C.

Origin C’s integrated development environment is called Code Builder. To open Code Builder, click the Code Builder button \textbf{[Code Builder]} on the Standard toolbar. Code Builder provides tools for writing, compiling, and debugging your Origin C functions. Once an Origin C function is compiled, the function becomes accessible from Origin.

\textit{Code Builder}

To learn more about programming in Origin, select \textbf{Help: Programming} or review the sample Origin projects located in the \texttt{\textbackslash Samples\textbackslash Programming} folder.
Chapter 2: Origin Basics

Script Window

The Script Window is available for executing LabTalk commands. LabTalk is Origin's "historic" programming language. It has been available in versions up to and including Origin 7. However, Origin 7 introduced the new Origin C programming language. Whereas LabTalk scripts are interpreted during execution by Origin, Origin C code is compiled to byte code form and therefore executes much faster than LabTalk.

Even though Origin C is the preferred programming language in Origin 7, Origin C functions must be called using LabTalk commands. These commands can be executed from the Script window, or from many other locations that support LabTalk script. To open the Script window, click the Script Window button on the Standard toolbar. Note that when you save an Origin project, the Script window contents are not saved with the project.

The Script Window

To learn more about programming in Origin, select Help:Programming or review the sample Origin projects located in the \Samples\Programming folder.

Origin Project Files

An Origin project file contains all the worksheet, matrix, graph, layout page, and notes windows that are open in the workspace when you save the project. These windows include minimized and hidden windows, as well as windows that are accessible from other Project Explorer folders in the current workspace.

Excel workbook windows are a special case. If a workbook is open in the workspace, the project can be saved with a link to the source workbook file, or the workbook can be saved internal to the project.

=> Saving the project with a link to the source workbook file allows you to maintain an external Excel file that is updated when changes are made to the associated workbook in Origin. This source file is also available for use in other applications and can be accessed by other users.

=> Saving the workbook internal to the project enhances the project's portability. You can open the project on any computer that has Origin and Excel installed and have full access to your workbook data. To control how the workbook is saved with the project, right-click on the workbook window title bar and select Properties from the shortcut menu.

In addition to these window types, the contents of the Results Log is saved with an Origin project, as well as the current Project Explorer folder and window structure.
Chapter 2: Origin Basics

Saving a Project

To save a project to the current file name, select **File:Save Project**. If the project has not been previously saved, this menu command opens the Save As dialog box displaying the default file name, UNTITLED.OPJ, in the File Name text box. Type the desired file name in the text box (specify the path) and click Save to save the project.

To save the project to a new file name, select **File:Save Project As**. This menu command also opens the Save As dialog box.

If you have developed a folder structure in Project Explorer, you can save a selected folder and its subfolders to a new project file. To do this, right-click on the Project Explorer folder that you want to save to a project file and select **Save As Project** from the shortcut menu.

**Saving a Project Explorer Folder to an Origin Project File**

In this example, the Linked Layers 1 folder and its Raw Data subfolder, all the windows that they contain, plus Results Log output specific to these windows are saved to a new project file.

Automatically Creating a Backup

Origin will automatically create a backup of the currently saved project file before re-saving. Origin renames the saved file BACKUP.OPJ, and then saves the altered file using the specified file name. The automatic backup feature is set on the Open/Close tab of the Options dialog box (**Tools:Options**).

Opening a New Project

A new project is opened each time you start Origin. You can also open a new project by clicking the New Project button on the Standard toolbar. In both cases, the new project contains one worksheet.
window. You can, however, customize the new project that opens. To do this, select Tools:Options to open the Options dialog box. Select the Open/Close tab and then modify the Start New Project setting.

Customizing the New Project Setting

You can select from worksheet, Excel workbook, empty graph, matrix, ORIGIN.OPJ, or none. The ORIGIN.OPJ file includes a worksheet and a graph window. The graph window is configured to display a data plot of column A (X values) and column B (Y values) automatically, after you import or enter data into the worksheet columns. You can customize the ORIGIN.OPJ project file and resave it. After you click OK in the Options dialog box, you are asked if you want to save this setting for future Origin sessions.

Opening an Existing Project

To open an existing project file, click the Open button on the Standard toolbar and select the desired file from the Open dialog box.

By default, Origin will keep track of the project file path, so that each time you open a project in the current Origin session, the path to the last opened file will be selected by default in the Open dialog box. To turn off file tracking or to specify a custom project file path, select Tools:Options to open the Options dialog box. Select the File Locations tab. Select Origin from the top list box and then click Edit. This opens the File Extension Group Defaults dialog box.

Customizing File Tracking
Chapter 2: Origin Basics

Origin Project Files

To specify a custom project file path, select User Path in the Open Path group and then browse to the desired folder from the associated text box. Click OK.

To set your Origin folder as the project file path, select Origin Path from the Open Path drop-down list. Click OK.

To direct Origin to always use this custom path, clear the Track File Dialog Changes on the File Locations tab. Click OK. An Attention dialog box asks if you want to save this setting for future Origin sessions. Click Yes.

Opening More than One Project

Origin can only open one project at a time. To open multiple projects, you must start multiple instances of Origin.

Appending Projects

The contents of a project can be added to the currently opened project by selecting File: Append or by right-clicking on a Project Explorer folder and selecting Append Project from the shortcut menu.
Appending Projects

After you select the project to append, Origin displays a Reminder Message asking if you want to append the contents of the new project into a new Project Explorer folder or into the current folder.

If duplicate window names exist between projects, Origin automatically changes the name of the appended window by adding an "A" to the window name ($AWindowName$). For example, in the following figure, a project containing a Data1 worksheet is appended to a project that also contains a Data1 worksheet. The appended window is renamed ADa1.

Renaming Duplicate Window Names when Appending

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADa1</td>
<td>Worksheet</td>
</tr>
<tr>
<td>Data1</td>
<td>Worksheet</td>
</tr>
</tbody>
</table>

Project Windows

Project windows include worksheet, matrix, Excel workbook, graph, layout page, and notes windows. You can create and open any number of windows in an Origin project. The only limitation is your machine's memory. However, you should keep your projects manageable by limiting the number of windows contained in a project. You should also consider organizing the windows using Project Explorer.

Creating a New Window

To create a new window, click one of the New Window buttons on the Standard toolbar.

New Window Buttons on the Standard Toolbar
These buttons create windows based on a default template. For example, the New Worksheet button creates a worksheet based on the ORIGIN.OTW template. You can change the template that is associated with any of these buttons. To do this, select File: New to open the New dialog box. To change the template associated with the New Worksheet button, select Worksheet from the list box, then select the desired template from the Template group. Click Set Default to associate this template with the New Worksheet button.

Changing the Template for the New Worksheet Button

You can also use the New dialog box to create new windows based on specific templates.

Renaming a Window

To rename a worksheet, matrix, graph, layout page, or notes window, activate the window and then select Window: Rename. Alternatively, right-click on the window's title bar and select Rename from the shortcut menu. Both menu commands open the Rename dialog box.

To rename an Excel workbook window, right-click on the window's title bar and select Properties from the shortcut menu.

When renaming windows, consider the following:

=> The window name cannot start with a numeral.
=> Origin ignores any spaces between characters.
=> The name cannot exceed 13 characters in length.

For greater flexibility in window naming, include the Label field in the window title bar. The label allows more characters and accepts special characters (for example, an underscore and dollar sign). It also allows spaces between characters.
Hiding a Window

To maximize the use of your workspace, you can hide windows from view - without deleting them from the project. To hide a window in the workspace, select the desired window icon on the right side of Project Explorer and then double-click on this icon. To return the window to the normal view mode, double-click again on the window icon. These view controls are also available by right-clicking on the window icon in Project Explorer, or by right-clicking on the window title bar.

Hiding a Window from View

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Raw D...</td>
<td>Folder</td>
<td>Normal</td>
</tr>
<tr>
<td>Conv...</td>
<td>Graph</td>
<td>Normal</td>
</tr>
<tr>
<td>Notes</td>
<td>Notes</td>
<td>Normal</td>
</tr>
</tbody>
</table>

Deleting a Window

To delete a window from the project, click the X button in the upper-right corner of the window. Origin then asks you if you want to hide or delete the window.

To prevent this verification prompt from displaying, select **Tools:Options** to open the Options dialog box. Then select the Open/Close tab. In the Window Closing Options group, select how you want Origin to respond when you click a particular window type's close button.

Setting the Close Option for a Window Type

<table>
<thead>
<tr>
<th>Window Closing Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worksheet: Delete Without Prompt</td>
</tr>
<tr>
<td>Excel/Workbook: Hide Without Prompt</td>
</tr>
<tr>
<td>Graph: Delete Without Prompt</td>
</tr>
<tr>
<td>Layout: Prompt</td>
</tr>
<tr>
<td>Matrix: Prompt</td>
</tr>
<tr>
<td>Notes: Prompt</td>
</tr>
</tbody>
</table>

Refresh a Window

Whenever you change the contents of a graph window or a worksheet, or expose a part of a window that was hidden, Origin automatically redraws the affected portion of the window. Occasionally, a portion of the window may not refresh correctly. Whenever this occurs, click the Refresh button on the Standard toolbar to refresh the active window.
Note: To control the percentage of the window that must be exposed before Origin automatically redraws the window, select **Tools:Options** to open the Options dialog box. Select the Miscellaneous tab and then edit the No Redraw (% Covered) combination box.

**Duplicating a Window**

To duplicate the active worksheet, graph, matrix, or layout page window, click the Duplicate button on the Standard toolbar. When a duplicate window is created, Origin names the window using the default window name syntax:

\[ \text{DefaultWindowNameN} \]

where \( N \) is assigned the lowest available number not used by other window names (of the same type) in the project.

**Default Window Names**

<table>
<thead>
<tr>
<th>Window</th>
<th>Default Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worksheet</td>
<td>WorksheetN</td>
</tr>
<tr>
<td>Graph</td>
<td>GraphN</td>
</tr>
<tr>
<td>Matrix</td>
<td>MatrixN</td>
</tr>
<tr>
<td>Layout Page</td>
<td>LayoutN</td>
</tr>
<tr>
<td>Function Graph</td>
<td>FunctionN</td>
</tr>
</tbody>
</table>

**Saving a Window**

In addition to saving projects, windows (except for layout pages) can be saved to a file. When a window is saved to a file, the window can be opened in any other Origin project. To save the active window to a file, select **File:Save Window As**. This menu command opens the Save As dialog box. Origin automatically lists the correct file extension for the active window type in the Save as Type drop-down list.
Window File Extensions

<table>
<thead>
<tr>
<th>Window</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>worksheet</td>
<td>.OGW</td>
</tr>
<tr>
<td>matrix</td>
<td>.OGM</td>
</tr>
<tr>
<td>graph</td>
<td>.OGG</td>
</tr>
<tr>
<td>Excel workbook</td>
<td>.XLS</td>
</tr>
<tr>
<td>notes</td>
<td>.TXT</td>
</tr>
</tbody>
</table>

Opening a Window from a File

If you have a window in one project that you want to include in another project, you can append the projects. However, this action will add all the windows from a selected project into the currently open project. To "append" only the desired window, you must save the window to a file and then open the window in the desired project. To open a worksheet, graph, matrix, or notes window that was saved to a file, click the Open button on the Standard toolbar. This button opens the Open dialog box. From the Files of Type drop-down list, select:

- "Worksheets (*.OGW)" to open a worksheet window.
- "Graphs (*.OGG)" to open a graph or function graph window.
- "Matrix (*.OGM)" to open a matrix window.
- "Text (*.TXT)" to open a notes window.

After you open a worksheet, graph, matrix, or notes window file in a project and then save the project, the window then remains a part of this project.

To open an Excel workbook file, click the Open Excel button on the Standard toolbar. After you select your Excel file, a dialog box opens asking if you want to open the workbook as an Excel workbook or as an Origin worksheet.
Opening an Excel Workbook

If you open the workbook as a workbook, you can continue to use Excel's spreadsheet tools to process your data, all within the Origin workspace. You also have access to Origin's plotting and analysis tools. When you are ready to save your project, you can save the project with a link to your source workbook, and update the link, or you can save the workbook as part of your Origin project. When you update the link to a (linked) workbook, the updated workbook is available for other applications or other users.

If you open the workbook as one or more Origin worksheets, you have no access to Excel's spreadsheet tools in Origin. Furthermore, the data no longer has a connection to the source workbook. Thus, the changes you make to the data are lost to the original workbook.

Window Templates

When you create a new worksheet, graph, or matrix window, (for example, by clicking the button on the Standard toolbar), Origin creates the new window based on a template. The template determines the properties of the new window. For example, if the new window is a worksheet, the template determines the number of columns in the worksheet, each column's plotting designation and display type, the ASCII import settings, and any formulas used to set the column values. If the new window is a graph, the template determines the number of layers (sets of XY axes) on the page and their arrangement, the types of data plots in each layer (for example, scatter or bars), the number of data plots, the axes scale type, and text labels and other annotations. Basically the template determines all the attributes of the window, except for the actual data the window will contain. Data is never saved with a template.

The following table lists the file extensions for the templates.
Chapter 2: Origin Basics

Template File Extensions

<table>
<thead>
<tr>
<th>Window</th>
<th>Template File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>worksheet</td>
<td>.OTW</td>
</tr>
<tr>
<td>graph or function graph</td>
<td>.OTP</td>
</tr>
<tr>
<td>matrix</td>
<td>.OTM</td>
</tr>
</tbody>
</table>

Origin provides many built-in templates. For example, most of the graph templates are accessible from the plotting toolbar buttons.

Plotting Toolbar Buttons

Origin also provides a Template Library tool for categorizing and accessing graph templates. To open the Template Library tool when a worksheet or an Excel workbook is active, select Plot:Template Library.

The Template Library Tool

Select Template

Category:
- Standard 2D Graphs
- Special Line & Symbol
- 3D X Y Z
- Statistical Graphs

Template:
- Plot

Preview

Category: Standard 2D Graphs
Template: Column.op

Plot Cancel
You can also use the Template Library tool to plot your worksheet or Excel workbook data. If you highlighted data in the worksheet or workbook before opening the tool, and your data selection is appropriate for the template you've selected, then click the Plot button to plot the data into the template. If you did not highlight data or if your selection was not appropriate for the template you've selected, then click the Plot button to open an intermediary dialog box for data selection.

To create a custom template, you can modify an existing template or create a new template. The procedure is similar in both cases. You must first open a window based on a built-in template, customize the properties of the objects in the window, and then save the window as a template. The instructions on rebuilding the window are saved with the template. However, any data in the window is not saved with the template.

For example, suppose you want to customize the template associated with the New Worksheet button on the Standard toolbar. To do this, click to open a new worksheet. Now customize the attributes of this worksheet. For example, perhaps you always import ASCII data files that contain data in the format X, Y, Y Errors. In this case, click the Add New Columns button on the Standard toolbar. Then right-click on the new column (C) and select Set As: Y Error from the shortcut menu.

To save this window as a template, select File: Save Template As. The built-in template ORIGIN.OTW is listed by default in the File Name text box. If you click Save, you will overwrite the built-in template with your custom settings. Alternatively, you can type a new file name to save your changes to a new template.

If you save to a new file name, you can associate the New Worksheet button with this new template file (it is currently linked to ORIGIN.OTW). To do this, select File: New to open the New dialog box. Select Worksheet from the list box. Then select your new template file from the Template group. Finally, click the Set Default button to associate this template with the New Worksheet button.
This page is left intentionally blank.